Land Rover and Range Rover Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
363 Posts
Discussion Starter · #1 ·
When I push the mode button I get the "S" on my dash board. And when I puch the mode button again. The truck goes back to manual mode, but I never get the "M" on the dash board. It does light up when I first start the truck. I am wondering. Should I get an "M" on my dash board when ever I am not in the sport mode? Thank's for any input.
 

·
Registered
Joined
·
490 Posts
BIRD said:
When I push the mode button I get the "S" on my dash board. And when I puch the mode button again. The truck goes back to manual mode, but I never get the "M" on the dash board. It does light up when I first start the truck. I am wondering. Should I get an "M" on my dash board when ever I am not in the sport mode? Thank's for any input.
I assume you're in a Disco II or a P38 Range?

Pushing the mode button on my P38 causes first a message on the dash which says "sport", and then changes to an "S." The light in front of the mode button also lights up to say sport.

Pushing it again causes the "S" to go off the dash and the light to go out.

Put it in low range, then push mode button. Manual will light up and the dash will say manual, then change to an "M." In this mode you can start off and stay locked in any gear while in low range. Very useful off-road.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top