Land Rover and Range Rover Forum banner
1 - 5 of 5 Posts

·
Premium Member
Joined
·
126 Posts
Discussion Starter · #1 ·
My daughter caught the bug much like me and had to have a Disco the only problem is she is not very mechanically inclined and I am stationed 1300 miles away..
She helped a friend out the am by jumping their car and she said her truck smelled as if something was burning. She shut her truck off and now it will not start again. Turns key everything does as it should but nothing when she tries to turn it over. If there is anyone who can take a look at it for her I would be greatly appreciated. It's a 2004 Disco LSE I believe and we drove it across country from Monterey Ca to Norfolk Va with no problems but she is starting to have them. She is also in the Navy so again this is kind of a plea for help....let me know if anyone is available to help...she cannot afford the Rover Shop charge but I will help out as I can..
Thanks
Joe
 

·
certified idiot
Joined
·
694 Posts
sorry Joe - I'm on the other coast - try posting on discoweb.org they are more active than this forum at the moment.
good luck
Barri
 

·
Premium Member
Joined
·
126 Posts
Discussion Starter · #3 ·
Thanks I appreciate it...I told her not to buy it since we are not stationed close together but I guess I gave that Rover bug to her after buying them over the years..
Joe
 

·
Registered
Joined
·
303 Posts
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top