Land Rover and Range Rover Forum banner

21 - 25 of 25 Posts

·
Registered
Joined
·
4,757 Posts
You love brutal cars to work on, I've seen the plenum covering your carbs. Quattroporte sounds so much better than - four door.

I understand you mind set, nothing wrong with it but it defeats the utility of what your driving - a Disco in this case - nothing rare about it.
I have a client who has one (and the speeding tickets to prove it). I do NOT work on that car, nor any other Italian car.

Rovers are masochistic enough.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #22 (Edited)
I also would not call a Discovery rare. However, to me anyways, I feel it to be a unique choice over the competition. I also like it in part because of my anti-American/Japanese, pro-British/European sentiment when it comes to cars. Same with the Quattroporte, and I agree it is a great way of saying 4 door. That car is rare, but that is not why I bought it. I just like the masculine lines, that 80's flash look, the attention paid to detail and the history. They could have built 2 or 2 Million, I would still like the car.

As far as masochism goes, I wouldn't consider myself as such. I just love cars and the payoff to cost ratio of these cars is reasonable enough for me. But sometimes it gets too much and I can get sick of hanging out under the hood of any particular one for extended periods of time. At that point I change gears and play with something else.

Another favorite car of mine, one I owned before the Maserati, is the Jaguar XJ-S V12 Coupe. None of these expensive cars, and I don't pretend they are by any means, but allot more interesting and unique than anything on offer today for a heck of a lot less initial cost.
 

·
Wounded Knee Moderator
Joined
·
1,904 Posts
What's a rare vacuum leak?

We've already come to a common agreement there is nothing rare about our Disco's.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #24
What I should have said is that it is leaking through the intake gasket, yet, it is only leaking air, not coolant. This I understand to be uncommon, but I may be wrong.

I also fixed my blower speed control, picture attached. Thank you PTSchram for the idea. It's just a small thing but it improves the truck as a whole immensely to me.

Total cost to fix the blower
4 switches - $1.75 ea
1 old license plate cut down - Free
5 Stainless screws - Free
1 coin tray that can't hold coins - Free
4 Feet 16 gauge - .29 ft
1 package of Female connectors and 1 Male - $2.00 ea
1 foot of shrink adhesive tubing - $2.40

Cost of the unit in the truck that I replaced 2 months ago $75
 

Attachments

·
Registered
Joined
·
2 Posts
Very low idle in drive at a stoplight (500 or so), it felt as though it had a huge cam in it. When I set off it went but occasionally and sporadically sputtered like it had run out of gas. It also backfired through the intake when I let off the accelerator and occasionally through the exhaust.

This was a surprise to me, happening all of a sudden, and I cant stand backfiring

I checked the timing first thing and it was spot on.

I quickly grew impatient as I am currently sick and it is very cold in the garage. So, I started messing with things I shouldn't have

To remedy this I adjusted the base idle, but I know I must have messed it up so that needs to be reset, and I pulled the plug to the coolant temp sensor and left it off. Now my idle is fine, or at least better, but now at lower rpms under 35-40mph or so it sputters every 5-10 seconds like it ran out of fuel for a split second which gets worse as it warms up. I also fiddled with the maf to attempt to lean it. After fiddling with it for about 1 hour it took all I had to not set it on fire, as I said, I am sick and impatient with it right now.

I replaced the fuel pump, injectors, cap, rotor, wires, plugs, ignition control module, coil, idle control valve, all vacuum lines, vacuum advance, serviced the centrifugal weights, tps, maf sensor, O2 sensors, all exhaust gaskets, resealed the upper intake, all parts replaced were OEM no china crap in my truck.

I think I am going to loose my mind
Fuel filter? get a new temp sending unit. reset the ecu. unplug it. turn on key and attempt to start. turn key off. and plug in ECU again..
 
21 - 25 of 25 Posts
Top