Land Rover and Range Rover Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi All,
I am a newcomer to the world of Land Rover and have just purchased a 2000 model XEDi S/Wagon as a solution to the usual impending arrival of children.

Being a novice to the world of LR, I am still adjusting from the transition between Freelander and Honda Accord Type-R and a syou can imagine, it is taking a while !

Now then, things I have noticed in the short time that I have had the car...........

Water Ingress........Boot and Sunroof both seem to be allowing water in. I have been told that the boot leak is common, but not sure about the sunroof. I keep getting dripped on !

HDC......I pulled the trigger and dropped the collar on the stick and the light never came on like I believe it should.

Windscreen Wipers........Passenger's side arm stopped altogether this morning whilst driving in the rain !


ABS.........The ABS light seems to stay lit on the dash for quite a while after starting the engine, although extinguishes before pulling away.

I was wondering if you more knowledgeable owners and enthusiasts would be able to tell me if these are common problems and whether there are any easy and quick fixes for them ?

Thanks in advance for your assistance and input.

Regards to all,
Russ.
 

· Registered
Joined
·
110 Posts
Rascal1003 said:
Hi All,
Water Ingress........

HDC......I pulled the trigger and dropped the collar on the stick and the light never came on like I believe it should.

Windscreen Wipers........Passenger's side arm stopped altogether this morning whilst driving in the rain !

ABS.........The ABS light seems to stay lit on the dash for quite a while after starting the engine, although extinguishes before pulling away.
Russ.
Water ingress - better get used to it or not park in the rain

HDC - the light is supposed to come on and the HDC is supposed to work. Unfortunately the wires at the bottom of the gear lever (in the boot) automatically rip themselves out of the switch - you need to make the wires longer and resolder to the switch.

Wipers - dunno - never had the problem - check the obvious like the splines are not stripped and the holding nut is tight

ABS - the ABS light does not go out until about 5kph - it is part of the self test system - the light stays on until the ABS computer receives a signal from the wheel sensors (5kph).

Hope this helps

Garry
 

· Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Thanks for the info Garry, much appreciated.

I sort of expected these problems. I am British and despite its parent owner company, so is Land Rover so should expect this sort of "average" build quality.


I have to say though that it is generally a pretty good car and should hopefully last me a fair while.

It seems like a fast-track learning experience into the Land Rover ownership, which I have to say, I half expected. Still, no regrets !
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top