Land Rover and Range Rover Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have 3 Land Rovers. 97, 98 and 2000 D2. I have questions about the charging system on my 98 Land Rover D1. My battery light on cluster does not show or is not illuminated at any time and has not since I bought it a year ago. Everything was working fine. Now SRS is being displayed as my tack, temp, fuel and then Speedometer have cascade failure. Then when flasher is activated, vehicle hesitates. I replaced with remanufactured alternator outside of O'reilly's Auto Parts store in Ash Flat, AR. First one was bad out of the box. Squealing bearing and not charging above 11.86 volts. Next one I purchased from AutoZone in Mountain Home, AR. They tested it in the vehicle Charging above 12.8 volts and battery tested good. 2 days later it failed. I had to prepay to order another alternator, wait 3 more days and then get refund on card and repurchase the replacement when the replacement arrived. That one only lasted 2 days. Is it because of where the parts are made or assembled. What Am I missing. When the last 2 replacements were installed all components were working fine.
 

·
very disco
Joined
·
2,740 Posts
welcome to the forum!

try posting your query with an appropriate title in the D2 sub. not many people read the new member introductions, let alone expect them to have requests for help
 

·
Expert Crate Digger
Joined
·
418 Posts
Welcome to the jungle. We’ve got fun and games…
 
1 - 5 of 5 Posts
Top