Land Rover and Range Rover Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Well... I fixed my last issues (thread: worst car i ever bought), but now see to have new problems.

I spent almost $3000 fixing the upper control arms, bushings, tie rods, battery, alternator and ac compressor.... I thought I had a well running rig.

A few hundred miles later while just casually driving down the road the yellow brake light comes on then the yellow air suspension icon and then the yellow dynamic stability control icon...

the car with then lower itself.

Is this a result of the mechanics doing something wrong when they put on the new control arms/tie rods/ect?

I have to take it to a GM dealership, so they might not have done something correctly... what should i have them look for.

edit:

also I just remembered about a new sound that is seemingly coming from the back (left?) sometimes on cold start ups....its like a whizzing sound inside the car.... zoooooom.....zooomm.......zooooom.... then goes away.

Air suspension seems to raise and lower fast enough... not sure if thats related...

These cars are CRAZY upkeep.

Thanks guys.
 

·
Registered
Joined
·
242 Posts
Step one on something like this is to check your brake lights, both that they're working(alone and with the sidelights switched on) and that they're about the same brightness side to side.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top