Land Rover and Range Rover Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I bought a used 2003 Discovery with 117k miles on it a month ago. My dad's good friend happens to be a mechanic who specializes in Rovers, he inspected the Discovery before purchase. After doing a few minor adjustments it was working fine up until a week ago. The service engine soon light turned on. The mechanic replaced the gas cap and the Light went away, until this morning when it started flashing ( it was steady when it was on before). I immediately returned to my driveway. The mechanic will come by today to check it out, but I've been searching through the Internet for clues. A couple of things that I have found:

Turns out that the VIN on this Rover is indeed on the "hit list" as someone else labeled it on this site. But at 117K miles, would it be unusual for my Rover to have an oil pump failure?

About a week ago, about an hour before the check engine light turned on, I pumped premium gas, but at a cheap gas station. I'm wondering if the gas I put in my Rover had some unusual additive that is affecting the drive. I do recall a sign at the station saying something to the effect that "this gasoline may contain ethanol". Is ethanol bad for Rovers?

I will greatly appreciate your advice!
 

· Registered
Joined
·
172 Posts
Your good with the gas. And it's not the oil pump, yet and it may never be. You should however have the computer scanned. If light is flashing it is something worst then solid. How was your rover running when the light came on?


Mike Russell
Age 18
2003 discovery se
Lover of Rovers
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top