Land Rover and Range Rover Forum banner
1 - 1 of 1 Posts

· Registered
16 Posts
Discussion Starter · #1 ·
Hello everyone,
I want to thank all of the good folks that offered info and advice during the driveshaft replacement. Thats all done and now im on to the second issue and my lack of info is slowing me down.
The truck is a 96 D1 w a 4.0 v8.
The fuel pump isnt pushing fuel.(no fuel from tank to injectors).
The folllwing is what i have already done based on posts i have already researched here....
I pulled the tank and removed the pump/float assy and tested the actual pump out of the sending assy and it worked well. I reassembled it and reinstalled the tank after cleaning and draining it and retested it and it worked.
Then i checked the fusebox on the right fenderwell and the fuel pump fuse as well as all of the others were intact and functioning.
I checked for power going into or out of the inertia switch. (Purple wires with a white stripe). Nothing. I checked to see if the inertia switch was tripped and it was not. I jumped the inertia switch and still nothing.
I presume the lack of electricity to the inertia switch is the location of the problem, somewhere between the fusebox and the inertia switch, right?
The truck runs great with starting fluid, but promply stalls when the ether vapors run out. Since it runs it is firing.... just not getting fuel.
Is there anything between the fuel pump fuse and the inertia switch? Or is there even supposed to be voltage in and out of the inertia switch...?
Any thoughts???
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.