Land Rover and Range Rover Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
Does anyone else have problems with a buzzing noise coming from the front vents!! It only happens at speeds usually over 50mph and is worse if it is windy!! My RR is a 2002 vogue model. :shifty: It sounds as though it is coming from the vent at the base of the windscreen in the middle!

Noooo replies yet... Please tell me someone else has this problem!!! apparently it only occurs on the early 2002 models..and i'm still trying to convince my dealer that i am not imagining it..

Cheers

Cam.
 

·
Registered
Joined
·
1 Posts
:dunno: I have a 99' Range and it appears to do the same thing at about 80mph and temperatures of 38 and below... If you find out let me know. I discovered this problem on the highway and I thought something broke. Everything under the hood looked ok......
 

·
Premium Member
Joined
·
16,594 Posts
Cam,
Have you inspected to make sure you have no sucked any leaves in from outside of maybe a business card from the inside, into the vent system??
Mike J.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thanks for your advice Mike, but i have found the problem to be air going down the back of the seal at the bottom of the windscreen on the outside at over 70mph. I ran some insulation tape across the seal from one end of the screen to the other and it appears to have cured it!

At least i know where the problem is coming from now, so it is going back to RR and they are going to check the windscreen seals out.

Cheers,

Cam.
 
1 - 4 of 4 Posts
Top