Land Rover and Range Rover Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey gang, I finally joined the ranks today by picking up 00 Disco. The truck looks to have been pretty well maintained and the story I'm getting from the PO is that it was a dealer demo for chaperoned executive off road excursions. 3" factory lift, sliders, skid plates, winch bumper etc. PO also had a 3 ring binder full of recent receipts in sleeve protectors of all of the recent maintenance. 170k on the clock but not a single rattle, chatter, clatter or drip anywhere in the engine compartment. And no abs light lol. All in all I'm very pleased with my acquisition. There are a few little things that I need to address or questions I have so here I am.

1. The 30amp fuse for the rear windows pops immediately when turning on the key. I imagine this is a simple ground fault somewhere. I ride and wrench a Ducati so I'm no stranger to a multimeter and the joys of electrical gremlins, but if there is one of those everyone-knows-it simple fixes I'm all ears.

2. I was showing my wife how elegantly the second row seats tumble forward and the shoulder belt for the middle seat has locked and won't let me put the seat back up. Is there a release somewhere that's easy to get to? I'm guessing the inertia lock is stuck but I don't want to resort to strapping someone into the suicide seat and yanking the second row while I hammer the gas lol.

3. This one is just weird. When I turn my lights on the the first setting everything is normal; the little running lights in the headlight housings light, markers, instrument cluster etc.. When I go full on headlights my dash goes completely dark and so do my tail lights.

I know it's probably been documented more times than anyone cares to read but I'll likely post up install pics when I get my mobile 2M/70CM installed. I'm running a MARS/CAP modded Kenwood TM-V71A to a Comet CA-2x4SR in my Pathfinder that's going to get moved over.

Anywhoo, that's where I am at the moment. Any input would be greatly appreciated.

Tia,
Ely
KK4NZM
 

·
Registered
Joined
·
3,198 Posts
I really doubt it's a factory lift, never heard of one before. The dealer might have installed it.
1. You're on track with a short. Get the ETM (Electrical Troubleshooting Manual) and start tracing.
2. No idea
3. My first check would be on the switch.

Here's a link to the soft copy version of the manual, which includes the ETM.
RAVE download
 

·
Premium Member
Joined
·
16,594 Posts
I agree, with Tom, Rover did not allow a dealer to do hardly any mods, and if any were done, it voided the warranty.
As for maintance, look at my Major service list and plan on doing it all to make it current, especially the front drive shaft inspection/replacement if it does not have 1 grease fitting on each of the 3 front u-joints.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Hmmm... Interesting info on the dealer mods. That makes sense though.

I'm downloading the RAVE manual now so hopefully I can get these electrical issues straightened out and I'll check out your service list. Thanks guys.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Cleaning up the contacts in the light stalk was a snap. No more headlight issues :) I'll have to wait until I can get it in the garage tonight before I start tearing into the wiring for the rear windows. It seems that my homelink is DOA too so there's another fun one to trace. Hopefully just a fuse.
 

·
Premium Member
Joined
·
16,594 Posts
How do you know it is dead?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
I guess technically I don't since I haven't checked voltage on it or even checked the fuse for that matter. Anecdotally though I'm going with the lack of led and that it wouldn't program. IIRC on previous vehicles it's usually no more than 20-30 seconds for it to go fast flash.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Dead, dead, deadski. Header pins ripped clean off the circuit board. I'm not even sure how one would "accidentally" do that. Had to dig to find the wire. I have a 12v A23 cell and holder somewhere. May do a quick hack solder job just to see if it's still operational. If so I'm sure I could replace those pins from digikey. Or just tape the battery to it and roll lol.
 

·
Registered
Joined
·
81 Posts
Check the binder or look around the vehicle for a Land Rover Special Vehicles plaque. I believe that LR-SV did do a few modified Disco's.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
Well, I've spent some time poking around the thing. I'm going to say old boy was probably full of it about the suspension. It's sporting OME bits under it. Also noticed a couple of cut lines by the rear suspension that lead back to an air compressor. Looks like she she had SLS prior to the lift.

That brings up another question. Has anyone used that compressor, maybe with a small tank, for airing up tires or activating lockers? Google wasn't much help. I'd love to see pics of the plumbing / how it's wired up.
 

·
Premium Member
Joined
·
16,594 Posts
It won't work, many have tried in the past.
Just curious, what did you pay for this truck?
 
1 - 11 of 11 Posts
Top