Land Rover and Range Rover Forum banner
1 - 2 of 2 Posts

·
Registered
2008 LR2 SE
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi,
I have a 2008 LR2 with a bit of an issue, and in search of help. My drivers side (LH) dual air control has stopped working, just blowing cold air. The right side works fine, but doesn't seem to be getting as hot or cold as it used to. I tried resetting the HVAC by holding down the auto and circulation button while turning on the ignition. After I did this the left side would spit out some warm, but not hot, air and then kick off. It repeated this several times. I heard a very faint buzz noise when the cool air would switch back. Ive been doing a little research and came across that it may be one of my stepper motors. Does this sound likely? Im considering a heater core flush, but would that be the main issue if one side is still functioning? Also about a week ago, I noticed a different sound from under the hood. It almost sounded like something was working harder than it normally does with a humming sort of noise. I am no where near an qualified mechanic, but I hope with some help from you guys and my mechanically talented father, I can fix this issue on my own. please help with your wisdom or advice if you can! thankfully ive been blessed not to have this challenge a week ago, when it was 2 degrees outside!
thanks,
kayley
 

·
very disco
Joined
·
2,983 Posts
I'm not sure if the LR2 resembles the LR3, but...

in the LR3 the exchanger is canted toward the driver side. this causes crud buildup on the left and eventually restriction of fluid movement through the exchanger on the left side. once it's gunked up, even a most thorough backwards flush may not work to clear it without descaler.
 
1 - 2 of 2 Posts
Top