Land Rover and Range Rover Forum banner
1 - 8 of 8 Posts

· 94 Defender 90
Joined
·
1,004 Posts
Discussion Starter · #1 ·
P0722 - Output Speed Sensor Circuit

My ABS, Traction Control, and Hill-Descent lights have illuminated on my '99 Disco2 and it's throwing a P0722 code. Can anyone shed some light on what should be checked? I'm guessing there's some dirt in the connector or it has come unplugged. Anyone know where this sensor is and how I can get at it? Any help would be greatly appreciated!

Thanks,

Chris
 

· Mod. --- I'm watching you
Joined
·
319 Posts
Let me see if I can look it up for you on my RAVE cd... just gotta boot up the laptop...
 

· Mod. --- I'm watching you
Joined
·
319 Posts
Can you give me the model truck you have and the options(does it have the ACE system)
 

· Mod. --- I'm watching you
Joined
·
319 Posts
Ok it sounds like it should be one of wheel speed sensors. I would check them all to make sure that there all plugged in and if they're all plugged in and clean then I would say one of them is bad... Start looking at the back 2 first...
 

· 94 Defender 90
Joined
·
1,004 Posts
Discussion Starter · #7 ·
Is there an obvious connector? Will I need to take the wheels off to easily access them? Is there a way to check if they're bad or not? Thank you for looking this stuff up for me. It's greatly appreciated.
 

· Mod. --- I'm watching you
Joined
·
319 Posts
You'll have to pull the wheels to check them. The connector should be on on the top of the brake. You should be able to see it pretty easy. I'm not sure if you can test it... I would think you could test the resistance but I'm not sure what it would be. I would check to make sure there all connected first and then move on from there.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top