Land Rover and Range Rover Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi, looking for advice on my 03' freelander, ive recently changed the thermostat housing, replaced coolant temp sensors, flushed radiator, despite all that, the fans wont turn on automatically, and though the engine doesnt get hot, coolant starts to leak from the expansive tank..... any help would be appreciated... thanks.....
 

·
2008 LR2 SE
Joined
·
37 Posts
I don't have that engine, but I would try bleeding the coolant system again. Air bubbles in the system will expand when it gets hot, and that can force coolant out.
 

·
Registered
Joined
·
22 Posts
I have an 02 that coolant started bubbling out of the reservoir. Engine got hot but temp guage went down after reaching almost the red area. I ended up replacing the head gasket since found out it was in bad shape. If your engine is not getting hot, try the bleed valve which is along the firewall next to brake booster. It's black plastic that has crosshairs on the top to relieve the pressure. Turn it counter clockwise but do not remove completely and start the engine and wait until there is consistent flowe of coolant out of the valve then re-tighten it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
I don't have that engine, but I would try bleeding the coolant system again. Air bubbles in the system will expand when it gets hot, and that can force coolant out.
Thank you Merlinj, ive changed the reservoir and cap with new ones, now im gonna try to bleed again.
 
1 - 6 of 6 Posts
Top