Land Rover and Range Rover Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
Hello, hoping someone can answer a quick question....yesterday I had the coolant line going from the rad to the overflow bottle blow off because of an "oversight" on my part lol
So it sprayed the engine with coolant and I got the MAF sensor code (actual code is escaping my memory) and the p0116 code. I'm just curious if the p0116 will go away once I refill the coolant?
I'm assuming my best option is going to be to replace the MAF rather than try to clean it to get rid of that code, am I correct?
Thanks in advance for any help!

PS I should mention that the truck is an 04 disco 2 with the 4.6l obviously.
 

·
Premium Member
Joined
·
1,598 Posts
Hi. Once erased that P0116 code should not come back if the coolant temp will not exceed the limit... unless the circuit has suffered some way
 
  • Like
Reactions: BKSRT8

·
Registered
Joined
·
53 Posts
Discussion Starter #3
Quick update: the new MAF I ordered showed up.....they sent the one for the 4.0l, so it's too small, but I made it fit just to see if it would work and it won't start....I couldn't get it to run with the old maf either and it did run a few days ago, but just barely....had to order coolant, picking that up tomorrow.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #4
So here's where I'm at.....coolant is full, new MAF and still no start....would the coolant temp sensor prevent the truck from starting? It cranks and will kick over a few times but never stays running....it smells SUUUPER rich too, is it possible the sensor is causing a rich condition and flooding the engine or causing plug fouling? Right now it's -14°C here so it's pretty bloody cold....if it's not the sensor, I'm lost, the coolant SEEMS to only have sprayed the MAF and drivers side of the engine, the actual sensor area is totally dry so unless it found some bare wire somewhere (not uncommon in this truck), I don't know where else to look.
Anybody have any suggestions?
 

·
Registered
Joined
·
1,852 Posts
Is it the correct MAF or the one you re-jiggered?

Is your throttle body heater bypassed by chance?
 

·
Registered
Joined
·
53 Posts
Discussion Starter #6
Sorry, haven't had time to update....I put coolant back in and it fired up eventually with the oem MAF which was the one sprayed with coolant....now I did remove it earlier and tried to clean it out as best I could with a qtip and some rubbing alcohol.....it idles a little rough now but if I can fix the line that goes to the overflow from the rad, I think it'll be drivable again. Still gonna have an overheating issue I think. I'll have to replace the MAF but I may try to clean it with actual MAF cleaner and see if it smooths out a bit.....maybe the coils got soaked and just needed a couple days to dry out?
Also, no, my throttle body heater is still untouched.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #7
So final update....I sold the truck yesterday, got more than I paid for it and somehow my 3 year long headache has almost entirely disappeared lol
Now, I'm in the market for a RR or RRS...just feels wrong not having an LR in the driveway
 

·
very disco
Joined
·
2,083 Posts
ooh get an RRS. I used to hate them (decidedly went in a different direction than what I valued LR for), but I ended up loving it, even missing it now that it's sold.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #9
I've found a couple rrs I like, trying to stay under $20k....I'd really like a 2015 or 2016 with the diesel but not looking to finance anything right now...I do like the full size RR more than the Sport but either way I'd be happy. Lots of research to do I guess, I know NOTHING about the 4.2l and 5.0l lol
 
1 - 9 of 9 Posts
Top