Land Rover and Range Rover Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
To begin I just bought a 2006 RR HSE non turbo from a local dealer. The car runs great around town and on short trips. The other day we were driving to vegas and it was very hot out. 103F. The car started throwing engine fault codes then it said transmission overheat and the car went into limp mode. There are no leaks to be seen under the car. I got a couple of different codes but now it is giving me a PO741 code. Since then the temp does not seem to be the biggest factor. These codes seem to fly mostly when Im driving fast on the freeway or uphill. There is no place to check the Tranny fluid so I cant see if it s simply low. I have an appt to take the car to RR next week to have the tranny flushed and the filter changed. The Trans cooler looks to be pretty straight forward. I personally doent think it could actually get clog. Any ideas? Thanks in Advance.
 

·
Registered
Joined
·
17 Posts
I have an 07 RRS HSE, very similar vehicle. I've not had that code but I did have some warranty work done recently. The trans has a fluid sensor that installs through the trans housing. No dip stick to check (poor design). My sensor line gasket was faulty/leaking,thus the repair. Def go to a RR shop. Can get very costly.


Sent from AutoGuide.com Free App
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top