Land Rover and Range Rover Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
sep 2018 had an alternator issue - replaced it with old one car came back to life then i have a voltage spike 15-15.5v intermitantly settled back to normal 14.2.... then one day as i was parking car it nust died then after a couple hours it would start again turned it around in parking lot and died again. Been sitting fir a whike now, charged battery to full and get same symptoms ignition key pos 1. 12v pos 2 6.7v and abs pump buzzing - disconnected pump and cylinder same symptoms - will try to post a video thinking of replacing alternator?
 

·
Premium Member
Joined
·
1,396 Posts
Might be the starter at fault and it creates excessive current draw... is it cranking slowly or not at all?
 

·
Registered
Joined
·
70 Posts
Discussion Starter #4
So after charging the battery to full, pumping the breaks like crazy, fiddling with the lock cylinder, electric cleaner, pushing the door lock pin I finally got the voltage to 12.4 and was able to start the car, ran the engine for a good 15-20 min, but alarm kicked in and horns were beeping weirdest thing ever, turned it off and then right back on, took a little huffing and puffing but kicked. On the third try nope, like that feeling when the gas mixture gets too hot did not kick, then voltage colaps again, push door pin that helped pumped breaks helped too

Thats where I am right now, most vacuum lines are bridle
 
1 - 4 of 4 Posts
Top