Land Rover and Range Rover Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
363 Posts
Discussion Starter · #1 ·
I just put on a new ARB brush bar. I did it at a good off road truck company. The ARB brush bar came with some small directional lights. The instructions said to hook the lights in to the main directional wires. It was straight forward. Black wire to black, red to red, and green to green. The problem is that now when I turn on the directional lights. My trailor indicatator light now comes on and blinks with the directional lights. The only thing anyone came up is with that the new lights are drawing more power and the truck now thinks there is a trailor attached. Does anyone have an ARB bar and had the same problem and how can I fix it. Other than that every thing went well with the lights.
 

·
Registered
Joined
·
106 Posts
are you talking about the turn signal lights, or did your bumper come with fog lights re-cessed in the bumper like the round ones? Are we talking about an arb bumper, or a brush guard? Any pics?

I had one on my tacoma and no probs there, even hooked up 4 hella lights.
 

·
Registered
Joined
·
8 Posts
Hi Bird, this is normal its because the extra bulbs are added for turning.

The system senses extra voltage being used for indecating and thinks a trailer has been plugged in :)

The only way round it that I have done is to use LED powered bulbs which use less power in one of the indecators to reduce the voltage being used :buttrock:
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top