Land Rover and Range Rover Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Well I have a bit of a problem thats a little dangerous.

I was wondering what could cause the car to "shut down" while driving it's quite worrying to say the least has anyone had this problem? Usually at speed (100Kmph) the car will totally shut down and the only thing alive is the service engine light which flashes on for approx 2 or 3 seconds then the car will actually kick off again as if nothing has happened. This has only occured 3 or 4 times and all I hear is the wind as I roll along but I wouldn't like to be overtaking when this happens, apart from that the cars running fine. Could it be something to do with grounding seems major to me can you "guru's" help me out at all?

Thanks :dunno:

Trendy
 

·
Premium Member
Joined
·
16,594 Posts
You're going to have to be alot more specifiv if you want any meaningful replys.
What year and model, how many miles, what sort os service, what does it take to restart????
Mike J.
 

·
Registered
Joined
·
321 Posts
as mike said need more info however what you can try is running you disco with an computer hooked up to it as you mentioned that your CE light will flash.. can find out what those codes are and go from there
take care
sam
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
It's a 1993 3 door V8i, 250k, manual.

It starts and stops of its own accord imagine driving along at 100k then the whole car shutting down for a few seconds then a kick and its back to normal. There is no warning and its smooth after, not sure if the comp will pick it up as its too intermittent. Just had a service, battery good, brand new leads, new solenoid, starter recond,air filter cleaned, alt putting out 14v etc it idles great, I can only put it down to electrical, do you think that the fuel filter/pump would make it cut out so dramatically?

I was hoping that it's happened to someone else and its an easy fix!

:drive:

Regards

Trendy
 

·
Premium Member
Joined
·
16,594 Posts
Trendy,
I would start with the fuel pump relay, I am assuming you change your fuel filter on a regular basis. How old is your fuel pump, it could be a player in your problem.
Mike J.
 
1 - 5 of 5 Posts
Top