Land Rover and Range Rover Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
240 Posts
Discussion Starter · #1 ·
Hello all,

2000 Land Rover Disco II, 175,000 miles

I have a problem that seems to be creeping up on me as I pump gas. I used to be able to pump gas full speed and now it is down to barely squeezing the nozzle and the nozzle will click off/no gas flow. I don't know if it is some kind of breather problem but it sounds as if I might get splashed with gas when I hear the nozzle about to click off, kind of like it is bubbling to the top.

As a note, I have been having the following codes show up (I believe I have 2 different problems going on).
P0455 Evaporative Emission, System Leak Detected (gross leak/no flow)
....I thought this was because I needed to change my gas cap, I would get this code and sure enough the gas cap was loose. Tighten it down and code stays away for awhile. I haven't changed it yet.

P1171 system too lean, bank A & B
P1174 Lambda Control adaptation fault bank, last occurrence - maximum signal

I know I have an exhaust leak and was going to run the Sea Foam through the air intake so I can find out exactly where the leak(s) is. Possibly the reason for the P1171 and P1174, idk.

Any idea where to check first for the gas flow problem?

Thanks for your advice.
-Heather
 

· Registered
Joined
·
240 Posts
Discussion Starter · #3 ·
I found an air leak on the intake manifold. Directly beneath the brake servo line there is a port that is open and sucking in air. It looks like it should have a cap on it. It is definitely an air intake port. Hopefully with that plugged up maybe I can see the lean codes go away!? I'll erase the codes and see what I get.
-Heather
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top