Land Rover and Range Rover Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
just bought a diesel freelander but already having problems! it runs beatifully but occasionally when we start the engine,it starts and then cuts out.usually when it hits 1000 revs. sometimes this happens time after time and we have to leave it for while before trying again. then it will start and run with no problems. we thought this may have something to do with the immobiliser. anyone had any simular problems? would be good to hear from you :confused
 

· Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
thanks for the info. had to have the recovery service out to it the other day and they thought it was the fuel filter as when they pumped the ball on the pipe it started ok. i've now had the fuel filter changed and all the clips etc relaced on the pipes. also had diagnostic done and everthing seems to be ok with that.
started ok when i collected it, got home, went to start it again...and it happened again!!! even after pumping it. feel like crying.
really stumped now...any suggestions?
 

· Registered
Joined
·
1 Posts
Having same problem

Hi Darren

We seem to be having the same problem, have had the fuel pump dismantled and a new ecu fitted. Still same problem occurs. Seems to be worse when weather is hot and also when tank is full. We wondered if the filler cap was not venting properly. Did you solve your problem? :confused
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top