Land Rover and Range Rover Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
490 Posts
Discussion Starter · #1 ·
1995 Range Rover 4.0 SE with stock radio, it has been working fine, then one day I turn it on (push vol. knob) and it comes on but when I turn the volume knob up or down, the volume does not change! However, I can still change volume by buttons on steering wheel. I have pulled radio out, disconnected all wiring, reset security code, etc--no result, it has been like this for a week now. Other than the volume knob, radio continues to operate normally. What's going on, anyone with an idea or has had this problem? Fixes?
 

· Registered
Joined
·
114 Posts
rheostat problem

:mad: Hi it is not uncommon to see this happen , you have to take dawn the radio and send it to a radio repair shop ,the axel got of the knob on the volume rheostat it is not very complicated to fix , but has to be done by an expert .
Saludos
pascal
 

· Registered
Joined
·
490 Posts
Discussion Starter · #3 ·
Is this in line with the fact that one day the volume worked just fine and the next day it didn't work at all?

Can I fix myself? Some skill in electrics.
 

· Registered
Joined
·
114 Posts
Have fun..

:eek: If you really know and have the tools for that, out of 10, I would say 8 so be prepared for some fun …but most important is to get the part if needed (normally have to order , and it takes some time ).
You need to be very calm , and remember to look and write the code number before you do anything so you wont have problems .Enjoy yourself …( remember to be very cautious and write dawn step by step so you can do it back words after …..)
Saludos Pascal
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top