Land Rover and Range Rover Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Hi there, I have a 92RRC, for months now when starting I've had to manually turn the key back to 'run' from 'start'. Over the last couple of weeks I have had to turn the key back and forth when starting until I get all the idiot lights to come on and then it starts, then manually turn it back to run. The problem now is that the start position and the run position are so close together with the off position that a lot of times I end up turning the vehicle off, and repeat....

You get the picture, here's my question, I obviously need a new ignition switch, but do I need the entire key/lock portion, or can I just replace the electrical part. I hoping the electrical part as it's a lot cheaper, but i just want it fixed at this point.

I appreciate the help!!

-Mike
 

· I'd love to be in the Rat Patrol
Joined
·
3,205 Posts
Have you looked at it yet?
I had similar problems and found the back of my ignition switch which is the electrical contact part to be very loose and fitting poorly.
I in a fit of emergency repair ZIP tied it back into position.
Haven't had any trouble since August.

It's incredibly simple how it works.
 

· Registered
Joined
·
31 Posts
Discussion Starter · #3 ·
Okie You Rock!! Thanks for the tip, I took it apart and the end of the electrical part was just hanging there, barely attached, I secured it like you said and now it's working as before. I'll appreciate the time this will buy me until I have to buy the part!!

Thanks again!

-Mike
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top