Land Rover and Range Rover Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Tachometer not working

I am having this problem with my tachometer. It starts out not working then maybe after driving for a little while it will start working again. Well now it has stopped working. Would really like some help please.

Thank You
 

·
Registered
Joined
·
229 Posts
KyleMan said:
I am having this problem with my revometer. It starts out not working then maybe after driving for a little while it will start working again. Well now it has stopped working. Would really like some help please.

Thank You
Hey you tawk funny :D just kidding you mean the tachometer right?
It looks like your alternator is crapping out, is your battery still fully charged?
 

·
Registered
Joined
·
11 Posts
I agree. The Tach lead on the Alternator was the first clue I had that my alternator was failing. That was followed by a trace flickering of the Battery light on the dash.

I replaced the alternator, belt and tensioner and all is once again well.
The good news is that this is one of the easiest alterator installations I have ever done. Two bolts, three wires and you are done. Better still it is right on top in the center. Can't get any better than that. On my brother's Pontiac, the engine has to be lifted to get to the alternator!! Luv working on my Rover!!:D


Hope this helps

Rob
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top