Land Rover and Range Rover Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 97 series I that will not start. The engine started for me one day and after 10 seconds cut out. There were no indications that the engine seized. I took off the fan and the crank will not budge left or right. Does anyone have any suggestions.
 

·
Registered
Joined
·
41 Posts
if there was nothing wrong with your oil pressure and you put the right oil in all the time then i do not know what happened to your vehicle, do you have anyone that is out for you and did you have your fuel checked, just saying this because there are people out there that will put suguar in your gas tank and that will make your engine sieze up fast. so if i were you i would get your fuel checked out because i never heard of that happening that fast. and i am so sry to hear that about your vehicle and i hope you get it fixed and lets hope no one did anything to your vehicle. i wish you the best, that is very strange if you ask me, i would check into that.
 

·
Registered
Joined
·
720 Posts
Bellrover - this sounds very odd! You say you ran the engine for 10 seconds - was it cold when you stared it up? I find it hard to imagine the engine seized after only 10 secs. I am assuming there is oil pressure - no instrument oil light on when you started it. What about the trans - did the motor happen to quit when you put it into gear? Could the brake at the back of the trans be stuck? Will the engine turn by hand if you put the trans into neutral (auto or 5 spd). What happens if you put her into gear and rock the truck back and forward? Just thinking out loud here...
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top