Land Rover and Range Rover Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
720 Posts
Discussion Starter · #1 ·
The red "Service Engine" light (high above the fuel gauge) just came on and I can find nothing wrong with our '96 Disco 1. The code reader shows nothing amiss and the owner's manual only mentions that the light is to alert the owner that the emission system should be checked at about 80k kilometers. We have only 83k on the vehicle since new. She passed Aircare last spring.

What should I check? The red colour of the warning light is a bit alarming but is this just a way to frighten the owner into the dealer's arms?

Thanks for any advice.
 

· Registered
Joined
·
268 Posts
Yes, that light is just a "friendly" reminder to throw money at the dealer. There is a little red box behind the passenger kick panel. Peel the sticker off it and poke something into the hole to reset the light.
 

· Registered
Joined
·
720 Posts
Discussion Starter · #3 ·
Thank you fishEH! Found the red "control unit" where you said it would be, worked it off the metal holding tab but couldn't get the sticker off without buggering it.

A small screw driver through the hole under the sticker might do the trick but can't find my keys.... arrgh. Will report back.
 

· Registered
Joined
·
2 Posts
Little more help...found the box and tried with a coffee stir stick. All I have at the moment...on the road. But is this reset with key on or off, or does it matter. Will you feel something reset or give way? Thought I did with the stir stick (fairly stiff), but light still on.
 

· Registered
Joined
·
720 Posts
Discussion Starter · #7 ·
You have to get the box out - wiggle it and it'll pull upwards and off the metal tab that secures it. I removed a yellow smaller box in front first to get a better grip on the red one..
You need a small screw-driver or drill bit or some kind of metal probe. Don't push it in too far. It will make contact with two wires just inside the hole. I think it worked with the ignition off.
Yes, i just poked through the sticker and will pay the consequences if they crop up.
 

· Registered
Joined
·
2 Posts
Got my Service Engine light reset. I ended up opening the top of box with 1/2" drill bit...be careful or you'll nick some wires inside (guilty). There's another thread showing a picture of two prongs that you need to short across to reset. With the 1/2" hole I was able to see the prongs...they are very close to the top. I originally thought I would use a small screw driver straight into the hole...won't work...at least not on 99 Disco I. My truck actually had 3 prongs...I used a right angle pick to short across all 3...or at least I think I did. Any way light is off...duct tape over the hole.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top