Land Rover and Range Rover Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
I've seem to notice a VERY slight vibration either in the drivetrain or engine in my "98 LSE. It is felt more in the acc pedal more than felt. I replaced the plugs and wires in hopes of making it disappear, but if anything I notice it more. I notice it only on acceration, and it seems to go away on overrun.There is a VERY slight irregularity at idle, but the truck runs great. No hesitation,ect and I get about 12-13 mpg in town. I have not scoped out the engine yet, hope to tomorrow. Is there anything I need to look for. I've replaced/changed just about everything I can think of. New shocks go on this weekend. I really have not looked at the drivetrain closely, except for fixing leaks and lube. I have had tires speed balanced ( which made a marked improvement !) and quickly checked suspention integrity. No problem I can see. I suppose a compresion check is in order, but haven't had the time..I have not looked into the flex disc either. Right now I'm thinking one of those is the problem. I hope to be finished with this project in another month so I can get this truck to my son.... Any info would be appeciated !!

PFZ
 

·
Registered
Joined
·
1,818 Posts
Is the irregularity at idle the same as on acceleration? If not, I suggest that you could have a slight inbalance in the drive shaft/s, seeing that it only occurs on acceleration and not when you back off.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #3 ·
Really I notice it on both occasions. At idle it seems light a light misfire, no vibration. Like I mentioned, this is VERY slight... Most people probably wouldn't even notice it. I tend to think it is more engine that drivetrain.. With 85,000miles on it, I'm looking at everything. After years of working on Porsches, I hear every noise...and alwats think the worst !! Thanks for the reply.

PFZ
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #5 ·
On the way from the office tonight, I think I have decided that there are two seperate problems. The slight misfire? could just be a lumpy idle.. The vibration is more likely running gear. The vibration is fairly constant on acceration, but lets up when I let off. No slop in drivetrain. Like I've said before , I'm probably just making too much out of this... I just don't want my son to have too much trouble with thus truck. It is a hell of a lot smoother than his "91 S-10 Blazer with 200,00 miles on it !!!!

PFZ
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top