Land Rover and Range Rover Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
i live 8 min away from work D2 is my daily driver....ive narrowed down to my stall problem to Crank position sensor, ive been limping g for 4 day while part comes in.... but it stall the same distance same stop light and same backstreet. i
is this normal or am i crazy
 

·
Super Moderator
Joined
·
2,153 Posts
Sounds typical for a crank sensor

many fault codes???
 

·
Expert Crate Digger
Joined
·
242 Posts
Yep typical. Buy a Bosch brand CPK.
 

·
Registered
Joined
·
232 Posts
Very often the Bosch CKPS is found in a house-brand box, such as a Duralast box at AutoZone. If AutoZone is nearest you and you would like to buy the sensor there, just open the box and see how the sensor itself is branded.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Sounds typical for a crank sensor

many fault codes???
no no codes. after 5 min or so it starts up with pike 1/2 sec hesitation.....get to work. i park it in gateted parking lot so i leave it running for upto 45 min whiled i prep for my service calls walk back to her ...... no stalls.....sitting and purring.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
92134


btw the heat shield looks like this...i had a spare on hand and use that...i wonder if this inhibits the sensor . cuasing it to over heat, sitting that it starts up a few minutes later...and ive read on here about the cold water trick over the bell housing
 

·
Registered
Joined
·
1,726 Posts
Sounds like typical CPS problem. Typical scenario - truck starts and runs fine while cold; after it heats up, it stalls and will not restart. Let it cool down and it starts up and runs again fine. Over and over. Not sure whether a bad CPS causes codes.
 

·
Registered
Joined
·
232 Posts
In the original post six days ago, the OP wrote "ive been limping g for 4 day while part comes in." Has the part come in? Then two days ago the OP posts video links with no further info. Were the videos taken before or after the CKPS was replaced? We're very willing to help, but we need more and better info.
 
  • Like
Reactions: reverendALC

·
Registered
Joined
·
5 Posts
Discussion Starter #10
In the original post six days ago, the OP wrote "ive been limping g for 4 day while part comes in." Has the part come in? Then two days ago the OP posts video links with no further info. Were the videos taken before or after the CKPS was replaced? We're very willing to help, but we need more and better info.
Surry Mates!

the vids are all from before any replacement of parts where done.....i did pull and cleaned in place the sensor, it was completely covered in oil not gummy just oily a few metal shavings 2 size grains of salt and 1 the sized of half a grain of rice....THIS PANDEMIC got me desperate tho mail service is slow IDK. I pulled 2 used ones from junk yard.(BTW out of the 300k junk cars in Harris county TX) only 3 discos were available) ....SO ive have poped in the cleaner one out the 2... 2 days running no hickups ...yet. That **** was hard! but not impossible!

durring my pissing and moaning under there.....and idea popped in my head ill be Googleing to see if anyone has already made one.

I wana THANK all muh RoVEr BrOS for pointing me in the right direction!

Ivan is a chonky boy!
 
1 - 10 of 10 Posts
Top