Land Rover and Range Rover Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
202 Posts
Discussion Starter · #1 ·
I just replaced my DI CDL shifter with an 04 style. Everything seemed fine and I went for a test drive. Now it's stuck in lo range and won't shift into park? I had to drive home in lo range. I'm stumped, please help.
 

· And I didn't even submit a proposal...
Joined
·
202 Posts
I'm late in replying to this, but when I did the CDL conversion on my 03 the battery got low at some point and I had that exact same behavior. I had that gear warning light in the cluster and couldn't get out of low and couldn't shift into park. I read in a few forum threads that a bad battery could do that and I was sceptical at first, but it ended up being the case.
 

· Registered
Joined
·
356 Posts
did you remove the solenoid on the transfer case while you were in there? sounds like that could be your culprit

certainly check battery first as that's the easiest
 

· Registered
Joined
·
202 Posts
Discussion Starter · #4 ·
I solved the "Park" problem. The c-clip wasn't installed correctly on the shifter cable.

I have removed the solenoid and still can't get it out of low range.
 

· Registered
Joined
·
356 Posts
must have something that is bound up
did you button everything up already? if so pull the boot off and see if you can get enough of a view down there and make sure everything is still connect as it should be.

otherwise you may be pulling it apart again to inspect :(
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top