Land Rover and Range Rover Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
So I bought a filter kit and set about to "service" the transmission. The problem is I don't know the service history. When I checked the level before I thought, hey it looks "pink" - sort of diluted - as it ran down the side of the pan. Then when I started to drain it today, it looks brown. Appears red on the edges where the light can get through. It doesn't smell burnt or really any worse than new ATF. At 113k miles should I just try to pump the quart or so I drained out back in (although from a new quart) and call it good or do the whole thing? I was thinking about drain and fill, drive for 1,000 miles, and then drain, fill, plus filter. I just don't want to put new fluid in it and learn I need a rebuild, which seems to be the risk.
 

·
Premium Member
Joined
·
16,594 Posts
Do 2 drain and refills, make sure to top of the tranny with a second refill while the engine is running.
As far as the second refill, just shift the tranny back and forth from drive to revers for 30 seconds and then do the second refill and add a bottle of Lucas tranny additive when refilling.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
Thanks. Should I bother with the filter or replace it between the two drains/refills?
 

·
Premium Member
Joined
·
16,594 Posts
Since you already have one use it on the second refill.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #5
Great, thanks for the help.
 
1 - 5 of 5 Posts
Top