Land Rover and Range Rover Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Good day,am new here but very happy to join this lovely forum cause have gotten some issues on my 05 LR3,it's jerk on the motion and display transmission fault limited gear available please.
 

·
Registered
Joined
·
1 Posts
Transmission fault, limited gears available

hello I have the same problems, where you able to get yours fixed? I have replaced my battery, brake light switch, rear brakes lights and my mass air flow sensor. I can't figure out what else it might be.
 

·
very disco
Joined
·
1,946 Posts
Pull codes. Could be any number of things, including a transmission fault. Five trucks may give that error for five different reasons.

the best thing you can do is give as much information as possible
 

·
Registered
Joined
·
2 Posts
Hi everyone, I have same problem, all gears engage normally PRND
But wehicle goes slowly and seems not to shift gears up or down, special programs olso are not available,
I tried a simple diagnostic tool and error p0659 is on.
Anyone has an idea?
 

Attachments

·
very disco
Joined
·
1,946 Posts
I’m unfamiliar with that innova tool, but I would definitely recommend using a tool loaded with LR specific software. I had codes pulled with an Autel tool, and later rescanned with my foxwell and the results were totally different (autel was wrong) and foxwell showed no record of the faults the autel suggested.

do you only have the ((P)) light when the car is acting up?
 

·
Registered
Joined
·
2 Posts
I’m unfamiliar with that innova tool, but I would definitely recommend using a tool loaded with LR specific software. I had codes pulled with an Autel tool, and later rescanned with my foxwell and the results were totally different (autel was wrong) and foxwell showed no record of the faults the autel suggested.

do you only have the ((P)) light when the car is acting up?
Yes only (p) because parking is engaged.
 

·
very disco
Joined
·
1,946 Posts
Oh, I had a similar issue on my RRS with the same symptoms but parking brake fault also.

does it do this all the time, or does the truck work normally sometimes?
 
1 - 8 of 8 Posts
Top