Land Rover and Range Rover Forum banner

1 - 4 of 4 Posts

·
certified idiot
Joined
·
692 Posts
Discussion Starter #1
Hi all
does anyone know if the transmission oil temp sender goes flaky?
just recently mine has been coming on, started off very infrequently so I would slow down or stop and wait but checking it and all seemed to be OK. just recently it has occasionally come on within 3 or 4 miles of starting and touching the transmission pan and / or the transfer case the temperature has been normal, and withing 3 or 4 miles the transmission pan is still cool.
wondering if these are known to go bad?
cheers
Barri
 

Attachments

·
Premium Member
Joined
·
16,594 Posts
Maybe there is a problem, when was the last time you serviced your tranny? As for that warning light, it will come on if the switch fails, if the tranny is over heating and if the t/case over heats
 

·
certified idiot
Joined
·
692 Posts
Discussion Starter #3
Thanks DM
tranny gets serviced every 20K and was last done maybe 3K ago, replaced the t/case oil at the same time. Tranny oil pan feels cool to the touch when the light goes on after a few miles. I might start to carry my laser thermometer just to get a temp, should eventually end up at the same temp as the water, around 85C.
I think its the switch but I will check for a week. towing a heavy load on my trailer today so a good test!
cheers
Barri
 

·
certified idiot
Joined
·
692 Posts
Discussion Starter #4
Light came on after 40 miles of towing 5000lbs. didnt go off again even after standing. The transmission pan was 182F and the transfer case was around 200f using my laser thermometer. sensor is supposedly set to go off at 250f so I am pretty sure its the sensor in the oil cooler but cannot find a number for it anywhere. anyone know the number?
found its UBI 100030
cheers
Barri
 
1 - 4 of 4 Posts
Top