Land Rover and Range Rover Forum banner
1 - 20 of 27 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Hi all.
I've seen this forum and decided to join as I have just bought my D2 V8
And hopefully enjoy my time here chatting to members with similar interests as me.

I have a rather confusing issue that I would like to discuss with you if you don't mind..
On start up (cold) the engine sound amazing, no noises
Let it warm up for 4-5 mins and turn it back off
Leave for 3 mins
Restart to have a loud knocking coming from rocker of lifter
And from then on its knocking

Oil viscosity has changed when warm, but what is causing the knocking
Poor oil pressure/worn pump
Oil too thin?
As the motor is new to me I don't know what oil is in there.

Any help would be great

Regards
Arv
 

·
Throwing Money at It
1995 Land Rover Discovery
Joined
·
72 Posts
What year? How many miles?

First things first, change your oil. It's a very real possibility that it's simply long overdue for an oil change, or the previous owner used the wrong weight oil. To be honest, I'm not sure what the best oil to use is, but I'm sure someone here will chime in.
 

·
Registered
Joined
·
1,166 Posts
Before you get side-tracked on which oil to use, you'd better use the search button a LOT and research the oil pump issues that 2003's are known for. See if your truck falls in the known VIN range for this issue and read, read, read, and then get back to us.
 

·
Registered
Joined
·
380 Posts
If you have any doubt of the oil he put in it, I'd swap it. Helical pilot is right, you could have a bad oil pump, just check the vin range effected and compare to yours, if you fall in between the lines you'll want to address that as soon as possible. I did my oil pump myself, wAsnt a painful job.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #7 ·
Before you get side-tracked on which oil to use, you'd better use the search button a LOT and research the oil pump issues that 2003's are known for. See if your truck falls in the known VIN range for this issue and read, read, read, and then get back to us.
Agreed I'm reading loads, not found how to check vin range yet, but being presumptuous I would say I have issues with pump.
I have decided to fit pressure gauge myself, and take the readings, I will get back to you with figures
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #9 ·
Search bad VIN range and then see if your's falls within it.
Thanks i was struggling to find it (im not the best on forums);)

so, mine looks to be just outside the range, being 3A817104

Ok, today i started it up completely cold and it sounds as sweet as a nut, so it isnt a one off, it seems to have a pattern.

can anyone advise me on a link to see how and where to connect the oil gauge so i can complete tests?
 

·
Registered
Joined
·
83 Posts
You can find my experience with a similar problem and what I checked and tried before fixing it here.

Tl; DR I fixed it, but tried way too many things in the process, save yourself the head/heart ache.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #11 ·
You can find my experience with a similar problem and what I checked and tried before fixing it here.

Tl; DR I fixed it, but tried way too many things in the process, save yourself the head/heart ache.
Thats what i do, look far to deep when the problem is on the surface.
glad you got yours sorted.

I've bought a oil additive earlier today, im not sure if it does the same thing but will give it a go, when i change the oil.
 

·
Registered
Joined
·
83 Posts
Thats what i do, look far to deep when the problem is on the surface.
glad you got yours sorted.

I've bought a oil additive earlier today, im not sure if it does the same thing but will give it a go, when i change the oil.
But seriously , before you start spending money, check the oil pressure numbers. That is the first step. You can tap into the oil cooler port, or where the oil pressure sender unit is installed for the dash gauge. Depends in what tool you're using to measure.
 

·
'03 Disco SE
Joined
·
573 Posts
I have an '03 in the "death range" that had similar symptoms to yours, but my knock was intermittent. I could go for 3 months without hearing it at times . I never tested the oil pressure but I've never tripped my oil light either. I pulled my timing cover to find my oil pump cracked into three pieces. Just because you're not in the VIN range doesn't mean your oil pump is safe.

Also an additive isn't likely to help much - the only way I can see it helping is if you have a stuck lifter caused by engine sludge. An additive with a high detergent content can break it loose, but it won't do anything against piston slap, rod knock, slipped liners, or spun bearings.
 

·
Premium Member
Joined
·
16,594 Posts
Oil is not your problem and putting some additive in is no fix.
Bet you never had a pre-purchase inspection done prior to buying it. bid mistake.
Per your question, I would say you are not at all mechanical, so a shop is probably to find and fix the noise.
I would warn you up front, this is going to be costly and I would suggest you get a couple estimates before you do anything.
More then likely, you may have a sleeve that is moving around which will make the noise you are describing
If you want some help, send me you number and lets talk before you do anything else.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #15 ·
Thanks for the help so far guys :)

Mike, appreciate your post, can I question the piston liner possibility..

I'm hoping it's not that, but I'm not going to worry even if it is, as I brought the truck for silly (cheap) money and its immaculate , so spending a few bux ain't going to break the bank.

If it were liner as you suggest, wouldn't it start with a random knock? Rather than a rhythmical knock?.

See my train of thought here is the liner would start to move once temp increases, and the knock would be random to start, but the knock is showing to be one that could resemble a rocker , maybe even brought on by oil starvation/low pressure.

Yes it could be oil actually, causing the noise,especially if the cheap after marker filter is anything to go by, then the oil quality could be poor and insufficient for my V8, and thus when the viscosity changes and becomes not adequate for my oil pump to keep the pressure.

Again you may well be correct with regards to oil, but I have now bought new filter and oil, including sump gasket too, as I'm going to check the pick up pipe and see what's around the gauze .

Obtw, I'm a qualified mechanical engineer, but as a rule I don't work on vehicles.;)
 

·
Registered
Joined
·
4,794 Posts
My money is on the oil pump gearset.

As for VIN range, I have seen this in every year of DII, but never in a DI or P38 for some reason.

I've had pretty good luck just replacing the oil pump gears.

If you can pass differential equations, you can fix your truck.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #17 ·
Update:


I have just learned the previous owner ran the oil excessively low then the noise started...
This brings a new element to the equation!
So if he did run it too low the first thing would be the pump would pick up, followed by bearings etc etc, well we know the majority sound nice and quiet still, so my money's on the pump and cam train.


I've decided on the above info to get it sorted, and a mechanic is going to give me a quote to change cam and lifters etc etc and while he is there change oil pump..
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #18 ·
Part update:
Land rover mechanic phoned today to say he has checked rockers and cam, and all looks good, no profile damage etc, so he has been advised to change out all hydraulic lifters.
Let's hope this is the answer ...
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #20 ·
Update:
New hydraulic lifters fitted, still the noise is there.
However he has admitted that the rocker cover can not be off to test/run engine, this is the opposite to what he was going to do...?
So for me the rockers could be causing the issue, as he didn't check when engine is hot,
So no noise when engine is cold...!!
 
1 - 20 of 27 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top