Land Rover and Range Rover Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
106 Posts
Discussion Starter · #1 · (Edited)
All right, i went up to the mountains today to go skiing, had a great time and no probs with the disco. But i get home and it dosent want to go into park. Shifts into 1,2,3,D,R just fine, but not park. So i make sure its not in 4 lo, or not engaged in 4hi correctly, but everything appears fine.
SO i push it harder into park and now its stuck in park, cant get it out of park. The warning lights for abs, traction control, and downhill assist are on solid. Finally, after waiting a while with engine off, i start it again and it shifts out of park, but very difficult.
Drive it, seems fine and shifts in all gears correctly. Try to put it in park, no go. Curse at it and still nothing. Help, key is in ignition and gear wont go into park, and dosent want to come out when in park. Any ideas? Im completly stumped. :dunno:
 

·
Registered
Joined
·
106 Posts
Discussion Starter · #2 ·
well i dropped it off at a shop, and they think it may be the shift linkage needs to be adjusted. still wondering why the abs, tc, and dnhill assist lights would show solid. hmm, lets see what else they come up with.
 

·
Registered
Joined
·
106 Posts
Discussion Starter · #3 ·
well it turned out to have 2 issues. 1, the shift linkage adjusted itself so they readjusted it back to where it should be-solving the not wanting to shift out of park to and forth. 2, an abs sensor on the right front wheel might be bad, reset the codes and well see if it pops on again. nothing so far. Just scared the hell outta me since we have only had it 2 weeks and i was thinking the gearbox was toast. all seems good now, we'll see.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top