Land Rover and Range Rover Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
218 Posts
Discussion Starter · #1 ·
I have a 01 SE7 Disco. i've got about 64K miles on it.
and the other day while driving the TC light came on then the M and S started blinking. when I stop the car and restart it it goes away. this has happened about 4 times a week so far. should I be concerned? has anyone had this issue before?

Also while driving it seems like it jerks a bit almost like if it was downshifting when on cruise control. but i've tried with and without the cruise. it does it ever so slightly. i know it's one of those things that if I take to the dealer they will think i'm nutz. but i drive from 2300ft down to sea level and back every day. and it can't be just the automatic tranny shifting. especially when I look at the Tac and notice that it's not changing any gears.

any insight? Help
 

· Registered
Joined
·
8 Posts
RudemanRB

I read somewhere (dont ask me where- might have been in the manual) that on cruise control the revs can be altered by the engine management system to deal with inclines. I have a TD5 manual disco with cruise control and it does the same thing...feels like it is downshifting only very slightly...the revs to drop around 250 revs.

Angus
 

· Premium Member
Joined
·
16,548 Posts
Transmission

RudemanRB said:
I have a 01 SE7 Disco. i've got about 64K miles on it.
and the other day while driving the TC light came on then the M and S started blinking. when I stop the car and restart it it goes away. this has happened about 4 times a week so far. should I be concerned? has anyone had this issue before?

Also while driving it seems like it jerks a bit almost like if it was downshifting when on cruise control. but i've tried with and without the cruise. it does it ever so slightly. i know it's one of those things that if I take to the dealer they will think i'm nutz. but i drive from 2300ft down to sea level and back every day. and it can't be just the automatic tranny shifting. especially when I look at the Tac and notice that it's not changing any gears.

any insight? Help
I would suggest you get into the shop quickly to have the tranny codes read, you have a problem starting to show up.
How many times has the tranny been serviced??
Mike J.
 

· Former LR tech, Albany NY
Joined
·
2,437 Posts
could be your MAF, unfortunately they arent designed to go up and down on a regular basis. They cant really adjust. You could reset adaptations and relearn it at a lower altitude but then it could have a problem at a higher altitude.

The only thing else to do is check for codes. If it is the MAF, I would suspect you have three codes. 0734, which is a fourth gear monitoring code and two lean codes bank one and two. If those codes are present you need a new MAF.

but have it checked for codes. The TC could be seperate but not neccessary.
 

· Registered
Joined
·
5 Posts
Could Beezel or others elaborate on MAF ( what is it?) codes and functions as I have excactly same problems on 2003 TD5 Auto and 3 different dealers have tried and failed to cure.
Gone into dealer again today with same problem.
Im not sure they know what they are looking for as it is intermitent and can happen after 5 miles or 100! but seems worse when under load eg pulling a caravan
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top