Land Rover and Range Rover Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter · #1 ·
I've got something weird going on with my brakes. When braking from 30 mph or below everything is fine, however above that i feel a pulsing on the pedal, the steering wheel doesn't shutter, and vehicle doesn't vibrate, just a slow pulse on the pedal (not like an abs pulse). Brake fluid level looks good.

-Jesse
 

·
Registered
Joined
·
317 Posts
plastic,
Although the whole vehicle doesn't shudder yet, I'd still think your rotors are warped. If you have a dial gauge you can test for this. How many miles are on the rotors? Might be time to just belly up for the rotors next time you swap out your pads...

Bogatyr
 

·
Premium Member
Joined
·
16,594 Posts
I agree, you are probably looking at rotors, and remember Rover rotors can't be resurfaced do to their soft material. How many miles on your brakes and rotors, how long has it been since you flushed your barke system, Rovers burn brake fluid quiclky and you land up with a soft pedal.
Mike J.
 

·
Registered
Joined
·
178 Posts
Discussion Starter · #4 ·
well, i just bought it two weeks ago. The used car dealer had it into the rover dealer just before i bought it for an abs light. it was a warped rotor but that problem was fixed. I'm pretty sure they replaced the rotor. Maybe it's just another rotor but isn't warped as badly.

I was wondering if maybe it's just a part of the suspension or something that might be loose. I checked everything i could and it all seemed tight. but anyway. it's probably just a rotor. The stopping distance seems fine. so i'm not gonna worry about it till i get the abs light.

thanks for your help.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top